Microsoft Defender has incorrectly flagged app.assently.com as unsafe

Incident Report for Assently

Resolved

This incident has been resolved.
Posted May 25, 2026 - 07:00 CEST

Update

Microsoft reported late Friday evening that they had reviewed our domain and found it to be safe. The block has been removed and customers should no longer have any problem reaching Assently's services.
Posted May 25, 2026 - 06:58 CEST

Investigating

Microsoft Defender has incorrectly flagged app.assently.com as unsafe, which causes warnings for some users who try to access the system. We have reached out to Microsoft to unblock us, and are waiting for their response.
Posted May 21, 2026 - 13:37 CEST
This incident affected: Assently E-Sign.