Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 10, 2026 - 10:30 CEST
Scheduled
As part of Verified, https://verified.eu/, we are streamlining our communications to give you a single, reliable source for all product maintenance updates and service alerts.
To better serve you during major incidents, this status page will be retired on August 31st, 2026. All status updates for Assently eSign and Assently CoreID are moving to our main platform status page at https://status.verified.io/.
Because subscriptions will not transfer automatically, please take a moment to resubscribe on the new page to continue receiving real-time alerts about operational events that might impact our systems.
How to Resubscribe on the New Page:
Go to https://status.verified.io/. Click the bell icon or Subscribe button to open the sidebar. Enter your email address and click Start subscription. Confirm the subscription In the component list, expand Verified eSign and Document Management to find Assently. Select Assently eSign, Assently CoreID, or any specific sub-components you want to monitor, and save your preferences.
Thank you for helping us simplify our updates and keep you better informed!
Posted Aug 07, 2026 - 13:41 CEST
This scheduled maintenance affected: Notifications (Email Notifications, SMS Notifications, Webhooks), Electronic ID Providers (Swedish BankID, Freja eID+, Finnish Bank Identification, Finnish Mobiilivarmenne, Finnish VRK, Norwegian BankID, Danish MitID), E-Sign Cluster 1 (E-signing (Cluster 1), Web Portal (Cluster 1), API (Cluster 1)), E-Sign Cluster 2 (E-signing (Cluster 2), Web Portal (Cluster 2), API (Cluster 2)), and Assently E-Sign, Assently CoreID, E-Sign Test Environment.