Degraded performance
Incident Report for Assently
Resolved
The problem has now been resolved. We will investigate the cause.
Posted Sep 04, 2020 - 17:22 CEST
Investigating
Degraded performance currently affects part of the system. Pages can be slow to load and some actions might fail. We are investigating the issue.
Posted Sep 04, 2020 - 17:13 CEST
This incident affected: Assently E-Sign.