Degraded performance on app.assently.com
Incident Report for Assently
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 12:27 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2022 - 12:15 CET
Investigating
Our quality systems are currently reporting degraded performance on app.assently.com. We are working on mitigation activities and status will be continuously updated.
Posted Nov 14, 2022 - 11:57 CET
This incident affected: Assently E-Sign.